Регламентированная отчетность в ЗИК

Регламентированная отчетность в ЗИК ФСС

Выгрузка реестра фсс 2021 для зик 7.7

Передача данных в ФСС по больничным и отпускам по беременности вызвала некоторые трудности у пользователей 1С 7.7. Для облегчения их участи создана эта обработка. Заготовку взял где-то здесь. Переделал почти полностью.

Только для 7.7 ЗиК
— больничные
— отпуска по беременности и родам

Порядок работы
Выбрать работать по больничным или по отпускам по беременности
Выбрать период
Нажать «ЗАПОЛНИТЬ»
— далее по необходимости удалить ненужные строки

Ну и сам файл кнопкой РЕЕСТР ПО ТАБЛИЦЕ

Для одиночных больничных выбрать больничный и кнопка «ВЫГРУЗИТЬ БОЛЬНИЧНЫЙ»

Версия выгрузки xml 1.7.2

Перерасчет фсс нс за предыдущий период в зик 315

Как выяснилось, проблема в алгоритме вида расчета «ФСС_НС». В реализации фирмы 1С расчет происходит следующим образом. Рассчитывается база (нарастающим итогом с начала года) на текущий период, затем из нее вычитается база на предыдущий перод. Полученная сумма умножается на ставку налога. Проблема в том, что разница этих двух сумм всегда будет равна базе текущего расчетного периода, не смотря на изменения налогооблажения некоторых видов расчета.

Решается проблема следующим образом. При расчете необходимо учесть суммы, исчисленные в предыдущих периодах, начиная с начала года. Для этого необходимо изменить часть программного кода в модуле вида расчета «ФСС_НС»:

//Nicholas [<>] ОАО «Рога и Копыта» 02.11.2021 17:34:09
//Comments: Перерасчет ФСС НС за предыдущий период в ЗиК 315
//Been:
//БазаТекущийМесяц = ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(СтрокаИтоговойТаблицы,»БазаФСС_НС»);
//Если Месяц>1 Тогда
//БазаТекущийМесяц = БазаТекущийМесяц — ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(СтрокаИтоговойТаблицы-1,»БазаФСС_НС»);
//КонецЕсли;
//// получим облагаемую базу инвалида
//БазаТекущийМесяцИнвалид = ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(СтрокаИтоговойТаблицы,»БазаФСС_НСИнвалид»);
//Если Месяц>1 Тогда
//БазаТекущийМесяцИнвалид = БазаТекущийМесяцИнвалид — ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(СтрокаИтоговойТаблицы-1,»БазаФСС_НСИнвалид»);
//КонецЕсли;
//
//ИсчисленоВзносов = Окр(БазаТекущийМесяц * ТарифФСС_НС / 100,2) Окр(БазаТекущийМесяцИнвалид * ПонижающийКоэффициент * ТарифФСС_НС / 100,2);
//Turn:

БазаТекущийМесяц = ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(СтрокаИтоговойТаблицы, «БазаФСС_НС»);
глСообщениеТрассировки(глСообщенияТрассировки, «База для расчета взносов по текущий месяц:_П01», 0,0, БазаТекущийМесяц, «Ч15.2»);

Читайте также:  Личный кабинет ФСС через Госуслуги для юридических лиц

БазаТекущийМесяцИнвалид = ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(СтрокаИтоговойТаблицы, «БазаФСС_НСИнвалид»);
Если
Месяц > 1 Тогда
БазаТекущийМесяцИнвалид = БазаТекущийМесяцИнвалид ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(СтрокаИтоговойТаблицы 1, «БазаФСС_НСИнвалид»);
КонецЕсли;

ИсчисленоПоТекущийМесяц = (БазаТекущийМесяц * ТарифФСС_НС / 100);
глСообщениеТрассировки(глСообщенияТрассировки, «Исчислено взносов по текущий месяц:_П01», 0,0, ИсчисленоПоТекущийМесяц, «Ч15.2»);

ИсчисленоПоПредыдущийМесяц = ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(СтрокаИтоговойТаблицы,«ИсчисленоФСС_НС»);
глСообщениеТрассировки(глСообщенияТрассировки, «Исчислено взносов по предыдущий месяц:_П01», 0,0, ИсчисленоПоПредыдущийМесяц, «Ч15.2»);

ИсчисленоВзносов = Окр(ИсчисленоПоТекущийМесяц ИсчисленоПоПредыдущийМесяц, 2)
Окр(БазаТекущийМесяцИнвалид * 0.6 * ТарифФСС_НС / 100, 2);
//EndNicholas [<>]

Расходы предприятия на цели фсс для 4-фсс с учетом иностранцев в зик

Регламентированная отчетностьЗарплатаЗарплатаv77::Расчет1С7:ЗиКРоссияБУФОМС, ПФ, ФССАбонемент ($m)

При подготовке к сдаче отчета в ПФР столкнулся с тем, что программа не учитывает переплату — не распределяет сумму уплаченных взносов, превышающую начисленную, даже если это оплата проходит в январе 2021 за декабрь 2021. В случае, когда есть долг по оплате на начало периода (например, за декабрь 2021 платят в январе 2021) сумма уплаченных взносов может быть больше суммы начисленных. Программа же ставит сумму уплаченных взносов равную сумме начисленных. В этой обработке распределяются суммы уплаченных взносов, превышающих начисленные, а так же внесены исправления, связанные с возможными ошибками при формировании штатной обработки из 335 релиза (в пачки попадали ненужные уволенные, неправильно распределялись уплаты взносов, при выгрузке в файл возникали ошибки).

1 стартмани

20.04.2021   
27282   
425   
mirrr   
65    

Регламентированная отчетность в зик

НалоговыеБухгалтерскиеРегламентированная отчетностьЗарплатаЗарплатаv7.71cv7.mdРоссияБУФОМС, ПФ, ФССБесплатно (free)

Нигде не нашел, отчет сырой, был нужен для сверки данных начисленной зарплаты. Указываем папку с файлами, передаваемыми в ПФР. После перебора всех файлов (XML), находящихся в папке, формируется список сотрудников, напротив каждого — страховая часть, накопительная часть, заработная плата.

Читайте также:  Фонд социального страхования пример

20.01.2009   
11188   
656   
Sea-harrier   
7    

Оцените статью
ФСС Help
Добавить комментарий